Troubleshooting

PennController for IBEX Forums Troubleshooting

This topic contains 46 replies, has 9 voices, and was last updated by Jeremy Jeremy 5 months, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 47 total)
  • Author
    Posts
  • #5840
    Jeremy
    Jeremy
    Keymaster

    Check the troubleshooting page for solutions to common problems. Use the forums if you don’t find a solution to your problem.

    #6751
    Avatar
    JulianaNovo
    Participant

    Hi Jeremy,

    I was already running a self-paced study (DashedSentence) and it was working nice and properly.
    Today I updated my stim list (.csv) and from that moment on my experiment is stuck on “Loading, please wait…”
    I thought it was something else on my .csv or script (troubleshooting page), but that’s not the case, because it was already working fine. I noticed though that if I cut my stim list in a half (the file has 194 lines), it loads fine.

    Any help here would be greatly appreciated.
    Best,
    Juliana

    #6753
    Jeremy
    Jeremy
    Keymaster

    Hi Juliana,

    Would you mind sharing your project’s demonstration link with me, so I can take a look at its script and csv file(s)?

    If the problem goes away when you delete some lines in your CSV file, then chances are that the problem does not lie with the script

    Jeremy

    #6755
    Avatar
    JulianaNovo
    Participant

    Hi Jeremy,

    Thank you!
    Here it is: https://farm.pcibex.net/r/jRLfWr/

    Many thanks in advanced 🙂

    J

    #6758
    Jeremy
    Jeremy
    Keymaster

    Hi Juliana,

    So if you turn the Debugger back on, you’ll get an error message saying “Format of table is invalid.” That message disappears once I remove all the " characters from your table, and the experiment then proceeds normally. You should in theory be able to use those characters, so I’ll have to investigate what’s happening. Fortunately for you, you don’t actually need them in your table, as your sentences don’t contain any commas (which are otherwise used to separate columns)

    Jeremy

    #6761
    Avatar
    JulianaNovo
    Participant

    Hi Jeremy,

    Thank you.
    In fact, if I remove all the ” characters from the table, it works just fine.

    The reason I had ” characters on my table is to avoid errors due to ‘diacritics’ and commas as well. In Portuguese language, we use diacritics, such as acute and circumflex accents and cedilla. Thus, I used to use either ” or html characters to avoid getting errors on the old Farm. I guess, the new one is recognising those characters as well.

    I was just wondering about what is happening, because my 10 trial list has ” and it is working fine. So, it has something else on my experiment preventing it to load the stim list.

    I am glad you were able to figure it out for now.

    Thank you!!
    J

    #7242
    Avatar
    noedoc1
    Participant

    Hi, Jeremy!
    I am programming a self-paced reading experiment and I was having the same problem as Juliana so I replaced the ” on my table for ‘. However, now I’m getting a bigger error. I think it’s not related to this, but rather it has something to do with the programming of the self-paced reading template.
    Here is the demonstration link to my experiment: https://farm.pcibex.net/r/EWhHDp/
    If you could take a look at it I would really appreciate it!
    Thanks!
    Noelia.

    PS: Thanks for including special characters in this new version of the PCIbex, as a Spanish speaker I really appreciate it!

    #7243
    Jeremy
    Jeremy
    Keymaster

    Hi Noelia,

    Your table uses ;s as separators. It should use either ,s or tabs

    Jeremy

    #7245
    Avatar
    noedoc1
    Participant

    Thank you, Jeremy! I changed the table and it’s working perfectly now!

    #7319
    Avatar
    btcotter
    Participant

    Hello,

    I’m currently trying to program a simple self-paced reading study with comprehension questions after each sentence. I have three conditions/groups (between subjects). Essentially, I just want my participants to be automatically assigned to one of the three groups when they begin the study. I’ve been following a few different tutorials/forums on how to program something like this using “Template” but I’m a little stuck on how to proceed, specifically with how to make sense of the syntax after “newTrial”. My CSV file that contains the experimental items has the following columns:
    1. Sentence (the actual sentence itself)
    2. Group (the group that it belongs to/the condition I want my participants to be automatically assigned to: A B or C)
    3. Item (1-40 to signify my 40 experimental sentences)
    4. Type (high, low, or global in terms of its ambiguity)

    How do you suggest I program the code if essentially I just want a simple self-paced reading design with the following columns implemented? Thanks in advance!

    Here is the demonstration link to my study: https://farm.pcibex.net/r/YekddE/

    #7320
    Jeremy
    Jeremy
    Keymaster

    Hello,

    There is no longer an experiment at the link you gave: you probably created that project when signed off and therefore didn’t save it into your account

    I have created a minimal variant of the self-paced reading template to integrate a table of the format you describe (with only 3 mock items though): https://farm.pcibex.net/r/nolGGc/

    As described in the tutorial, participants will be assigned a group based on the project’s internal counter, which is incremented only once a submission is received (which is the default behavior). Complete a test run once and take the experiment again to see another group, or use ?withsquare=N in the URL to override the counter’s value

    Let me know if you have questions

    Jeremy

    #7489
    Avatar
    afarin
    Participant

    Hi Jeremy,

    When I run a trial version of my experiment, it skips the first part (which is a practice round) and does not play any of the audio or display the text for the practice. Instead, it just plays through the audio files for the main part of the experiment, and does not display the text that’s supposed to accompany it. I can’t find what the issue is. I am getting an error message when I turn the debugger on which says ‘Ambiguous use of getTextInput(“TextInput2”): more than one elements were created with that name–…” I can’t figure out what this error means, and I’m not sure if that’s what’s causing parts of the experiment not to show up. Here’s a link: https://farm.pcibex.net/r/LUXXXk/

    #7491
    Jeremy
    Jeremy
    Keymaster

    Hi,

    Your Sequence references the labels “test1” and “test2” when it should reference the labels “practice1” and “practice2”:

    Sequence( "intro", "instructions", "test1", "test2", randomize("experiment"), randomize("part2"), randomize("part3"), SendResults() , "bye" );

    You remove your Text element immediately after you print it (only printing a TextInput element in the meantime):

    newText("Answer", "How far is this word from English?")
       .center()
       .print()
    ,
    newTextInput("TextInput2")
       .center()
       .print()
    ,
    getText("Answer")
        .remove()

    In the lines that come just after, you create a new TextInput element that you named “TextInput2”, just like the one you create before, so PennController won’t know which one you mean when you use getTextInput("TextInput2") later on:

    getTextInput("TextInput2")
        .remove()
    ,
    newTextInput("TextInput2")

    Jeremy

    #7498
    Avatar
    afarin
    Participant

    Hi Jeremy,

    Thanks so much, sorry for bothering you with such a silly error!
    I have a question about audio playback- I would like each audio file to play twice, with 3000ms in between. The audio files are presented in a random order using the command

    newAudio("Audio", row.Audio)
    .play()
    .wait()

    If I use .play(twice), the audio loops indefinitely. Is there an solution to get the audio files to play twice that I’m missing?

    Thanks!

    #7500
    Jeremy
    Jeremy
    Keymaster

    Hi,

    There is no “twice” option for the Audio element’s play command. The “once” option is only there to prevent a second play from looping after it’s been called with “loop” a first time

    Even if passing “twice” made the element play twice, the program would have no way of guessing that you want a 3000ms pause between the two playbacks

    Why don’t you just do

    newAudio("Audio", row.Audio).play().wait()
    ,
    newTimer(3000).start().wait()
    ,
    getAudio("Audio").play().wait()

    ?

    Jeremy

Viewing 15 posts - 1 through 15 (of 47 total)

You must be logged in to reply to this topic.