Creating a .csv file that can be read in PCIbex Farm

PennController for IBEX Forums Support Creating a .csv file that can be read in PCIbex Farm

This topic contains 4 replies, has 2 voices, and was last updated by Avatar annebez1 1 week, 1 day ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #6817
    Avatar
    annebez1
    Participant

    I created a test stimulus file in Excel and saved it as a .csv file. When I uploaded it to PCIbex Farm and tried to open it, I got the following error message

    “Error opening file chunk_includes/items1_C.csv: Internal Server Error”.

    I then tried opening the .csv file in a text editor and could see that there were characters that were unrecognized. I fixed those so they looked okay in TextEdit (on a Mac). But that file when uploaded to PCIbex Farm gets the same error message.

    I know that Qualtrics which accepts stimulus files in .txt format requires that these text files be in unicode 8 (UTF-8). Is something like this going on with my .csv files too?

    Any help would be much appreciated.

    #6819
    Jeremy
    Jeremy
    Keymaster

    Hi,

    When PennController cannot read a CSV file, it would normally throw an error in the Error tab of the Debug window. What you are describing is different, and I don’t think I’m familiar with this error. Where do you see it, is it in the web console?

    In any case, feel free to share the demonstration link of your experiment (“Share” option in the right menu on your project’s page), whose copies will contain a copy of that CSV file

    Jeremy

    #6822
    Avatar
    annebez1
    Participant

    Dear Jeremy,

    The error message pops up in a pink box in the bottom right-hand corner of the screen.

    Here is the link: https://farm.pcibex.net/r/Dylanu/

    I should say that what I have working so far is thanks to you. You created some of the script that you ran with a mini .csv file (with 2 faux items). If I use your .cvs file as a seed file and copy additional items into it, the script I have so far runs and does what it is supposed to (cycle through items based on group).

    I could keep doing this…using you .csv file forever as a seed file. However, it would be good to know what I am doing wrong when I try to create a file from scratch in the manner I described above (using Excel and a text editor).

    AB

    #6823
    Jeremy
    Jeremy
    Keymaster

    I think what happened is that the stylized double-quote characters were not properly handled by Excel and/or TextEdit, which would cause the exported CSV file to be unreadable once uploaded onto the PCIbex Farm.

    You should replace those characters (both the opening and the closing ones) with ": that expression will be rendered as a double-quote character by the browser running the experiment

    I just tested it and it worked: I couldn’t directly open the file items1.csv in the PCIbex Farm editor (just like you reported) so I downloaded it (checked the box to the left of its filename, then clicked the “download” icon) then opened it in a text editor, replaced all occurrences of the character � (which had replaced the stylized quotes) with " and re-uploaded it back to the project. The experiment then ran smoothly, and I was able to open the file directly in the project’s editor

    Jeremy

    • This reply was modified 1 week, 2 days ago by Jeremy Jeremy.
    #6827
    Avatar
    annebez1
    Participant

    Thank you for the swift resolution of this problem, Jeremy. (:

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.