Materials preloaded but not shown in the experiment

PennController for IBEX Forums Support Materials preloaded but not shown in the experiment

This topic contains 5 replies, has 2 voices, and was last updated by Avatar anitajookyeong 1 week, 3 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7019
    Avatar
    anitajookyeong
    Participant

    Hello, I am having problems with loading images and audio files in the experiment.

    I know that it is not the problem of accessing the zip file from my server. I made a practice trial using a small zip file and it worked perfectly. Also, according to the Debug function, downloading and preloading the zip folders was successful. However, when the experiment begins, I don’t see any images nor hear any audio files. It only gives me texts.

    I wonder if I am having this problem because having 12MB of materials for one experiment is too much?
    What can I do to solve this problem?

    #7020
    Jeremy
    Jeremy
    Keymaster

    Hello,

    Would you mind sharing the demonstration link to your project, either here or at support@pcibex.net?

    Jeremy

    #7025
    Jeremy
    Jeremy
    Keymaster

    The problem was coming from a trailing / at the end of the URL pointing to the zip file in PreloadZip: the Log tab from the Debug window gives a warning that the “entry […] is not a valid URL” (I will move this to the new Warning tab in the next release of PennController

    Jeremy

    #7040
    Avatar
    anitajookyeong
    Participant

    Thank you for pointing out the problem!
    However, that does not seem to be the main reason why I don’t see the images/audios because, for the practice trial, both images/audios were zipped together in the “practicetask2.zip” file. This zip file was pre-downloaded successfully but I still didn’t get any images/audios for the practice trial.

    #7041
    Jeremy
    Jeremy
    Keymaster

    Did you clear your cache and refresh the page where you run your experiment? Your practice material has always preloaded just fine for me, I was just having preloading problems for the experimental trials (which I no longer experience since you fixed the trailing /)

    Jeremy

    #7042
    Avatar
    anitajookyeong
    Participant

    Oh you are right! After removing the cache, I got all the materials in order. I did remove the cache once in a while when I was setting up the experiment, but I didn’t know it was this crucial in running the experiment.
    Thank you so much for the help!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.