‘How to use a spreadsheet’ tutorial – Experiment not loading

PennController for IBEX Forums Support ‘How to use a spreadsheet’ tutorial – Experiment not loading

This topic contains 12 replies, has 4 voices, and was last updated by Avatar Larissa_Cury 2 weeks, 6 days ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1313
    Avatar
    Matthew Hunt

    Hi,

    I’ve been following the tutorial and have got to the section on using a spreadsheet. I’ve followed the steps, created the spreadsheet (as .CSV) and have copied the code across. When I try the experiment, it’s stuck on ‘Loading, please wait’ but never goes anywhere. Is it possible I don’t have the right branch of the repo URL? I continued on the ‘rating-input’ one seeing as this section uses scales.

    Let me know if you need any more info on the problem.

    Best,

    Matthew

    #3696
    Avatar
    grusha.prasad
    Participant

    Following up on this. Did you ever manage to find a fix? I am running into a similar issue.

    Thanks!

    Grusha.

    #3697
    Jeremy
    Jeremy
    Keymaster

    Hi Grusha,

    This is a topic I imported from the forums on the previous website, but somehow the replies got lost in the process. The solution, in Matthew’s case, was to open the CSV file from the project’s page, using the online editor, and simply save it without bringing any change to its content. That got rid of the byte order mark, which causes format compatibility problems.

    Be aware though that seeing an endless “Loading, please wait” message can have different causes. I’m currently working on the next release of PennController, which comes with a debugger that prompts some helpful error messages. If you’re willing to try it, sync your project using the URL https://github.com/PennController/Sync/, making sure to replace master in branch/revision with 1.4, which is the number of the next release (click Update from git repo in your project to unfold the repo url and branch/revision fields if you can’t see them). Be aware that it’s still a version under development though. If you need to come back to 1.3, just type master back in branch/revision and sync again.

    Let me know if you have any questions!

    Jeremy

    #3698
    Avatar
    grusha.prasad
    Participant

    Hi Jeremy,

    Thank you for your response. I managed to figure out what the issue with my CSV file was. Will use 1.4 for future issues I need to debug. Thanks again!

    Grusha.

    #7196
    Avatar
    Larissa_Cury
    Participant

    Hi!

    I’m trying to sync my Pcibex project with my GitHub html but it isn’t working. When I type your code it works perfecly. Whenever I try to upload my own html, the option button to select a branch doesn’t work, I don’t know why 🙁

    ps: I’m trying to sync with github in an attempt to run my experiment. Whenever I upload a 100x50px png picture it works properly, but whenever I try to upload a bigger file I get stuck on the wait message. With the 100x50px, my pic resolution is terrible, that’s why I’m trying to upload a bigger file…

    #7197
    Jeremy
    Jeremy
    Keymaster

    Hi,

    If the button to select a branch doesn’t work, it probably means the git URL is not valid. Here is an example of a valid URL: https://github.com/penncontroller/sync. Note that you cannot selectively sync one folder or file at a time. The following is *not* a valid git URL: https://github.com/PennController/Sync/tree/master/js_includes

    What is the size of the bigger file that you are trying to upload? Note that each account on the PCIbex Farm has a 64MB quota, which applies to the total of files across all your projects

    Jeremy

    #7198
    Avatar
    Larissa_Cury
    Participant

    Hello, again, Jeremy, and thanks for your response!!

    Well, I still can’t sync Github, I’m trying to copy the link at the “main” Github screen which appears when I click on the green button “CODE”, then I copy it and try to put it on Pcibex. (it’s my first time using Github, I’m probably doing sth wrong…)

    Well, I always get this problem with my images and they’re very small…whenever I try to make it bigger with a better resolution I get stuck forever on the message “Please wait while the resources are preloading. This may take up to 1min.”

    an example: (files 100x50px), working properly properly: https://farm.pcibex.net/r/PtEROF/

    ps: It sounds fun, I was getting the message on every single attempt to run a bigger image, now that I was creating a new code to send it to you it worked with 300x200px, thogh if you could still take a look at it cuz It was the first time it worked properly…

    ps: I forgot to include in the instructions, but the keypress would be either A,B,C or D

    • This reply was modified 3 weeks, 2 days ago by Avatar Larissa_Cury.
    • This reply was modified 3 weeks, 2 days ago by Avatar Larissa_Cury.
    • This reply was modified 3 weeks, 2 days ago by Avatar Larissa_Cury.
    #7202
    Jeremy
    Jeremy
    Keymaster

    Hello,

    When copying the link from the green “CODE” button on github, make sure you have ‘HTTPS’ selected and not ‘GitHub CLI’ or ‘SSH’. Also make sure that the folders and files in your repository are properly structured as an Ibex project, with your files in their respective *_includes folders. Like this, for example.

    You project with 100x50px image files works well for me too. Do you have a link to a project with bigger resolution images that doesn’t work, so I can try to identify the problem?

    Jeremy

    #7209
    Avatar
    Larissa_Cury
    Participant

    Hi, Jeremy!

    So, I was able to copy a proper link from github! (it’s a start!), thank you. However, If I delete the pics from Pcibex and try to use only the pics I’ve upload to gitHub, even after syncronization, it doesnt work.

    GitHub: https://github.com/LariCury/test_includes.git
    code w/ Github sync: https://farm.pcibex.net/r/mEGsdU/

    About being stuck forever on “Please wait while the resources are preloading. This may take up to 1min.”. I really don’t know what happenned, I’ve always got this problem whenever I tried to upload a biggerr file (smaller than 64mb), even with the code I’ve sent you before, It wasn’t working but now It’s working properly with 300×200 and I didn’t move a finger!

    Many thanks again,

    #7210
    Jeremy
    Jeremy
    Keymaster

    Hi,

    The folders and file in the github repository at https://github.com/LariCury/test_includes.git do not have the structure of an Ibex experiment: if you look at this repo for example, you’ll see three directories: chunk_includes (Resources), data_includes (Scripts) and js_includes (Modules)—project can have a fourth folder, css_includes (Aesthetics)

    If you want to import images to your project’s Resources by syncing a git repo, you need to place those images in a folder named chunk_includes at the root of that repo (for example, just rename folder_includes to chunk_includes)

    Other than that, there’s something weird that happened with the project at the link you gave, where main.js is listed twice under Scripts—something for me to look into. Anyway, glad that the 300×200 images now work properly!

    Jeremy

    #7211
    Avatar
    Larissa_Cury
    Participant

    It worked, Jeremy!! Thanks a lot!

    I’m wondering…Now that I’m using my Github directory, I thought that the files wouldn’t be uploaded to Pcibex as well. I was able to sync my pics from Github using chunk_includes, but when I did that, the files appeared on the upload section of Pcibex as well, so it’s still using Pcibex’s memory? Another question: if my directory is “private”, then Pcibex wont be able to read it or there’s no problem?

    I have another question regarding uploading stuff into Pcibex. I’ll be running my test in portuguese, which means that I need some caracters such as ´ and `. When I upload the sentence:

    A menina é estudante (the girl is a student) into a .CSV table, Pcibex reads it properly, however, if I try “A menina está doente” (the girls is feeling sick), I get an error message, is there something I can do? I can write “á” If I don’t use a table, but I’d like to use one…

    Thanks a lot again, Jeremy!

    #7212
    Jeremy
    Jeremy
    Keymaster

    The ‘Sync’ option just copies all the files from the git repo to the PCIbex Farm, so yes, it does use storage space, which is why it counts toward your quota. If you have files on Github you can directly reference their download URL, eg. newImage("https://raw.githubusercontent.com/LariCury/test_includes/main/Imagem-1-A.png")—you can also add AddHost("https://raw.githubusercontent.com/LariCury/test_includes/main/") at the top of your script and then use newImage("Imagem-1-A.png"), newImage("Imagem-1-B.png"), etc. in your trials if you need to reference multiple files from your github repo

    The PCIbex Farm won’t be able to see your private repositories, so you won’t be able to sync them to your projects

    It shouldn’t be a problem to directly have diacritics in the CSV file, I just tried and it worked—double-check whether you use commas in your sentences, which would be interpreted as separating columns. If you have any comma that’s not supposed to separate two columns, you can replace them with ,; likewise, you can replace any á with ´, any é with &ecute;, any à with à, any è with è, …

    Jeremy

    #7213
    Avatar
    Larissa_Cury
    Participant

    Jeremy, I can’t thank you enough!

    I was able to use AddHost, now I’ll try to become familiar with it. Indeed, now I can read my CSV. file as well!!

    Thanks for your precious advice (and for your patience with me!)

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.